Photos -- thanks to Old Toad and google

Discussion created by profchiara on Jul 20, 2014

Are any of you known as Old Toad?  If so, I owe you one!


I had a near life-ending experience this morning.  I have suffered three computer crashes over the past four months with my college computers, Mac Probooks all.  The next-to-last time they recovered most things thanks to their backup system, but I lost my Kodak Easyshare software with all my album titles.  Although I no longer use a Kodak (I have a Canon SX40 HS), and Kodak is out of the photo business, the software still worked till that crash.  I had to rename everything in pics etc.  Then the revamped computer they gave me crashed, so I finally have a new one.


Then today the unthinkable happened -- which I hope will be a reminder to all of you to back up photos.  I have used iPhoto since the major crash, so while the vast majority of my previous photos (about 15,000) are now listed under pictures in Applications, all of those taken since the crash were on iPhoto (654 to be precise), including many of those I shared from Crete and Santorini.  I was beyond horrified.  Everything I tried didn't work, and albums I knew I had titled did not show up under find.


That's where google and Old Toad come in.  It turns out this happens a lot (do a search under "all my photos on iPhoto disappeared" and you'll see).  Fortunately, after trying several different things that didn't work, I came upon Old Toad's advice on trashing the old version, updating to the new, and 'rebuilding the library.'  After a few dead-ends, it worked!  0 photos went back to 654 after all the steps he (I don't know why I assumed he except a woman probably wouldn't choose that nickname) suggested.


I don't know why it occurred to me that someone on MRI might be Old Toad, but it did.  If so, come forward, saver of photos!  But I learned an important lesson.  Photos are one of my most valuable possessions, and the thought of losing even some of them nearly gave me coronary arrest.


When in doubt, google!  (And back-up, though that was not the problem here -- there seems to be a glitch in iPhoto.)